Close

Results 1 to 15 of 15
  1. #1
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22


    Yes Reputation No

    Exclamation Trouble shooting ESS CFR 525 SC Kit for M3 CSL

    Hi Guys

    I have a problem with one of my friends M3 CSLs with the CFR525 kit. Here is the situation in detail:

    Situation
    M3 CSL has the CFR 525 supercharger kit installed for a little bit over 2 years now.
    No retune for the ECU has been done since the first tune from ESS
    The rpm fluctuates intermittently when idle and the car shuts off when approaching a speed bump or traffic light (to a stand still)
    The car is running on the rich side, AFR's are all over the place.

    Complication
    Tried all of the following without avail:
    Did some housekeeping around the engine bay (especially manifold) and tightened all hoses, clamps to eliminate any potential vacuum/air leak
    Installed new air pressure sensor, as it was giving us faults on the GT1
    Installed new O2 sensor as it was giving us faults too, when the new air press. Sensor was installed.
    Installed new upgraded oil pump from VAC (assuming that the old one might have been weak)

    I will be speaking to someone at ESS but before I do that I thought someone here must have experience with this and be able to help. Cheers.

    Ejaz
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  2. #2
    Join Date
    Apr 2010
    Location
    Earth
    Posts
    5,173
    Rep Points
    526.1
    Mentioned
    4 Post(s)
    Rep Power
    6


    Yes Reputation No
    Has contact been made to ESS about the issue?
    Click here to enlargeClick here to enlarge

  3. #3
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22



    Yes Reputation No
    Click here to enlarge Originally Posted by GG///M3 Click here to enlarge
    Has contact been made to ESS about the issue?
    Oh Yeah were talking to ESS and were working it out little by little.

    I thought maybe someone had the same issue and would be able to tell us but now we will dyno the car tomorrow and then ESS will tell us what to do.

    Also this problem started after someone removed the intake manifold to fix something and then reinstalled it.

    Today when I spoke to ESS they were awesome in explaining the whole trouble shooting guide Click here to enlarge
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  4. #4
    Join Date
    Feb 2010
    Location
    Boston
    Posts
    879
    Rep Points
    891.7
    Mentioned
    63 Post(s)
    Rep Power
    0


    Yes Reputation No
    Uhhh think you answered your own problem. Start there you probably have a vacuum leak.

    BG

  5. #5
    Join Date
    Feb 2010
    Location
    Corpus Christi, Texas, United States
    Posts
    3,106
    Rep Points
    1,236.6
    Mentioned
    6 Post(s)
    Rep Power
    13


    Yes Reputation No
    Is it a MAF car? My Z had the same problems, it involved turbulent air across the MAF sensor and the tuning was not precise enough to "catch" it. The car would die if engine dropped near idle speed while moving (clutch in, neutral while coming to a stop sign for example). I would have to keep some throttle on to keep the engine from stalling.

    For my 300zx (two intakes), the solution was modifying the area under my nose panel to not direct air directly at the filters, and I ended up attaching another MAF that was spliced into a little controller that averages the signals between the two MAFs before sending it to the stock ECU (canned EPROM tune).

    Runs great now.

  6. #6
    Join Date
    Feb 2010
    Location
    Corpus Christi, Texas, United States
    Posts
    3,106
    Rep Points
    1,236.6
    Mentioned
    6 Post(s)
    Rep Power
    13


    1 out of 1 members liked this post. Yes Reputation No
    Click here to enlarge Originally Posted by 0-60Motorsports Click here to enlarge
    Oh Yeah were talking to ESS and were working it out little by little.

    I thought maybe someone had the same issue and would be able to tell us but now we will dyno the car tomorrow and then ESS will tell us what to do.

    Also this problem started after someone removed the intake manifold to fix something and then reinstalled it.

    Today when I spoke to ESS they were awesome in explaining the whole trouble shooting guide Click here to enlarge
    Just saw this. If you can, get your hands on an Automotive Smoke Machine. You will be able to pressurize your entire intake tract by sealing off at the filter area and using shop air to push smoke into a vacuum line connected to your intake piping or manifold. The smoke will push out of any leaky areas, allowing you to see the problem and fix it. It will also tell you the amount of air leaking, in inches water column usually.

  7. #7
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22



    Yes Reputation No
    Click here to enlarge Originally Posted by BrenM3 Click here to enlarge
    Uhhh think you answered your own problem. Start there you probably have a vacuum leak.

    BG
    Well that's the thing, we removed and reinstalled everything back nice and tight. We will see tomorrow with the dyno and so on
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  8. #8
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22



    Yes Reputation No
    Thanks everyone for your advice, I have a good bunch of ideas but just wanted to see what solutions you all had in mind. I'll update tomorrow.
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  9. #9
    Join Date
    Aug 2010
    Location
    Bay Area
    Posts
    977
    Rep Points
    779.1
    Mentioned
    5 Post(s)
    Rep Power
    8


    Yes Reputation No
    Click here to enlarge Originally Posted by SlicktopTTZ Click here to enlarge
    Is it a MAF car? My Z had the same problems, it involved turbulent air across the MAF sensor and the tuning was not precise enough to "catch" it. The car would die if engine dropped near idle speed while moving (clutch in, neutral while coming to a stop sign for example). I would have to keep some throttle on to keep the engine from stalling.

    For my 300zx (two intakes), the solution was modifying the area under my nose panel to not direct air directly at the filters, and I ended up attaching another MAF that was spliced into a little controller that averages the signals between the two MAFs before sending it to the stock ECU (canned EPROM tune).

    Runs great now.
    im thinking its a MAF issue too.

  10. #10
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22



    Yes Reputation No
    The cars mafless. This kit is mafless, we did not see any mafs in the kit
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  11. #11
    Join Date
    Feb 2010
    Location
    Corpus Christi, Texas, United States
    Posts
    3,106
    Rep Points
    1,236.6
    Mentioned
    6 Post(s)
    Rep Power
    13


    Yes Reputation No
    Click here to enlarge Originally Posted by 0-60Motorsports Click here to enlarge
    The cars mafless. This kit is mafless, we did not see any mafs in the kit
    So it uses a MAP sensor? It shouldn't fluctuate much from a small vacuum or boost leak then... maybe it has to do with idle fuel trims, cold/warm setting, tps or something?

  12. #12
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22



    Yes Reputation No
    I will let you all know as soon as I find out. This Thread will be useful for people if they face similar issues once we solve this. Im also curious and will do a compression and leak down test on the car.
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  13. #13
    Join Date
    Aug 2010
    Location
    Valley Stream NY
    Posts
    3,350
    Rep Points
    2,779.7
    Mentioned
    85 Post(s)
    Rep Power
    28


    Yes Reputation No
    Sounds like a vacuum leak to me.

  14. #14
    Join Date
    Mar 2010
    Location
    Kingdom of Bahrain
    Posts
    2,700
    Rep Points
    2,103.6
    Mentioned
    27 Post(s)
    Rep Power
    22



    Yes Reputation No
    Click here to enlarge Originally Posted by Matt@Camber-Toe Click here to enlarge
    Sounds like a vacuum leak to me.
    Im praying to GOD it is!
    Click here to enlarge



    EURO 04 M3 Current Mods:GC DAs, Eibach Sways, PF RTAB's, RE RCAs, INTRAVEE II, Black Roundels, ///MFEST Badges, Depo's, Screen protector for NAV display, VCSL Bumper + Race Lip & CF Trunk & CF Rear Diffusor, DIETZ TV in Motion, SS= V1 Headers + catless pipes + X-Pipe + SS Sport Exhaust, Z8 Starter Button, Lamin-X, OEM CSL interior, OEM CSL Steering, OEM CSL Intake, OEM CSL Roof, MSS54HP + OEM CSL Tune, BBS CH's, LIGHTWERKZ, 355mm ST40 BBK, BW Oil Cooler....

  15. #15
    Join Date
    Jan 2011
    Location
    Norway
    Posts
    172
    Rep Points
    416.3
    Mentioned
    4 Post(s)
    Rep Power
    5


    Yes Reputation No
    any update? got it figured out?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •