Close

Results 1 to 7 of 7
  1. #1
    Join Date
    Aug 2010
    Location
    columbia sc
    Posts
    274
    Rep Points
    897.3
    Mentioned
    4 Post(s)
    Rep Power
    9


    Reputation: Yes | No

    Help AT transmission problem

    I have an 07 E90 car seems to shift fine in drive but now when I kick the shifter over in DS mode to shift through the gears myself, it allows me to downshift through the gears but unable to up shift to higher gears.

    For example I kick it over in DS then downshift it into 4th I am unable to shift to 5th or any gears above that. Same if i started in 1st unable to shift to 2nd or above.

    It will shift on its own if i rev it all the way out to redline but I have no manual control anymore shifting to higher gears.

    Thoughts please.

  2. #2
    Join Date
    Feb 2010
    Location
    NJ
    Posts
    13,460
    Rep Points
    58.0
    Mentioned
    318 Post(s)
    Rep Power
    0


    Reputation: Yes | No
    hhmm.. you been playing with wiring at all? what about codes? I vaguely recall a few people having an issue similar to this when some of the wires under the shifter became worn through..

    i think Hotrod had that issue @Terry@BMS you recall anything like that?

  3. #3
    Join Date
    Aug 2010
    Location
    columbia sc
    Posts
    274
    Rep Points
    897.3
    Mentioned
    4 Post(s)
    Rep Power
    9



    Reputation: Yes | No
    No codes and have not played with anything. Thanks LM appreciate any help.

  4. #4
    Join Date
    May 2011
    Posts
    172
    Rep Points
    117.1
    Mentioned
    6 Post(s)
    Rep Power
    2


    Reputation: Yes | No
    Click here to enlarge Originally Posted by newb335guy Click here to enlarge
    No codes and have not played with anything. Thanks LM appreciate any help.

    Doesnt matter if you never messed with the shifter. Likely there is a "pinched" or broken wire under the shifter. You need to take it a part. Should be an easy fix.

  5. #5
    Join Date
    Aug 2010
    Location
    columbia sc
    Posts
    274
    Rep Points
    897.3
    Mentioned
    4 Post(s)
    Rep Power
    9



    Reputation: Yes | No
    Thanks guys yea weird when I kick it over into DS mode it shows DS in the cluster and the gear will show in the cluster gauge if I downshift to a gear but when I pull back on it nothing just stays in the gear I downshifted in and wont shift.

  6. #6
    Join Date
    Jun 2012
    Location
    NJ
    Posts
    4,198
    Rep Points
    1,800.2
    Mentioned
    102 Post(s)
    Rep Power
    19


    Reputation: Yes | No
    Are you having this problem just with the shifting knob or do you have paddles? And are they giving the same problems?
    COBB AP ProTune by Bren of ///Bren Tuning
    Akrapovic DP | Helix FMIC | Alpina TCM Flash | Walbro 450LPH Fuel Pump


    "The moment money becomes your motivation, you are immediately not as good as someone who is motivated by passion and internal will." -A. Senna

  7. #7
    Join Date
    Aug 2010
    Location
    columbia sc
    Posts
    274
    Rep Points
    897.3
    Mentioned
    4 Post(s)
    Rep Power
    9



    Reputation: Yes | No
    Click here to enlarge Originally Posted by benzy89 Click here to enlarge
    Are you having this problem just with the shifting knob or do you have paddles? And are they giving the same problems?
    I do not have paddles. Base model

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •