Close

Results 1 to 15 of 15

Thread: LPFP Issue

Hybrid View

  1. #1
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0


    Reputation: Yes | No

    LPFP Issue

    This weekend I had my LPFP (Part number: 16147163298), and Fuel pressure regulator replaced. Now I get code 2AAF. Even when I clear the code, and just start the car, and check, the code comes back. I was wondering if it could be because I didn't replace the LPFP sensor?
    Last edited by Turkeybaster115; 11-12-2012 at 11:58 AM.

  2. #2
    Join Date
    Nov 2011
    Posts
    453
    Rep Points
    662.4
    Mentioned
    17 Post(s)
    Rep Power
    7


    Reputation: Yes | No
    Don't sweat the 2AAF code. Mine has been there since day 1. I'm sure almost all Cobb users have it.
    Click here to enlarge
    PTF Tuned Cobb Stage 2+ | H&R / Koni Sport | BBS LM

  3. #3
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Yeah, but I will need to pass emissions testing later on, and this won't pass the ecu query. Also, I had this code only when racing/using E85, and the car had high mileage. When driving around the code wasn't being thrown. It's now being thrown in normal driving after the LPFP replacement! So something is causeing this. I wonder if you have to replace the sensors, kind of like with the brakes. The car has smart sensors, that can tell when you replace stuff.

  4. #4
    Join Date
    Nov 2010
    Posts
    404
    Rep Points
    758.8
    Mentioned
    11 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Unlessl it's triggering a check engine light or preventing readiness, it shouldn't affect your emissions testing.

    Neil

  5. #5
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by MDORPHN Click here to enlarge
    Unlessl it's triggering a check engine light or preventing readiness, it shouldn't affect your emissions testing.

    Neil
    In my neck of the woods, they do an OBD check of the vehicle for emissions purposes. I thought they flag you, if they see any codes at all. Or maybe it's just the ones related to emissions?

  6. #6
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by JStang Click here to enlarge
    Don't sweat the 2AAF code. Mine has been there since day 1. I'm sure almost all Cobb users have it.
    Do you throw the code, when you flash back to stock? I just want to be certain that it's cobb induced.

    Thanks

  7. #7
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    919
    Rep Points
    780.4
    Mentioned
    42 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Turkey,

    What stage and map vesions are you running and what version of the AP firmware? I've seen this 2AAF every now and then but mostly during part throttle/off throttle situations and only with the v.401 maps.
    From all the things I've lost,
    I miss my mind the most!
    Click here to enlarge

  8. #8
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by vasillalov Click here to enlarge
    Turkey,

    What stage and map vesions are you running and what version of the AP firmware? I've seen this 2AAF every now and then but mostly during part throttle/off throttle situations and only with the v.401 maps.
    I8AOS, very latest firmware (will check to give the exact one), Stg 2+ FMIC aggressive, V4.02
    Last edited by Turkeybaster115; 11-12-2012 at 04:24 PM.

  9. #9
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    919
    Rep Points
    780.4
    Mentioned
    42 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Click here to enlarge Originally Posted by Turkeybaster115 Click here to enlarge
    I8AOS, very latest firmware (will check to give the exact one), Stg 2+ FMIC aggressive, V4.02
    Hmmm. Exactly like me. I do get this code once every 2-3 months and it is always during part throttle/off throttle situations. Anyway, if the code keeps coming back for you, send an email to Cobb Tuning. Rob or Ian are very fast to respond and they might have some ideas.
    From all the things I've lost,
    I miss my mind the most!
    Click here to enlarge

  10. #10
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by vasillalov Click here to enlarge
    Hmmm. Exactly like me. I do get this code once every 2-3 months and it is always during part throttle/off throttle situations. Anyway, if the code keeps coming back for you, send an email to Cobb Tuning. Rob or Ian are very fast to respond and they might have some ideas.
    Alright, thanks. I have triple digit mileage, so I changed the LPFP on saturday, along with the Fuel pressure sensor, Oem charge pipe, and dv's. Car showed very big improvements. It certainly had a weak LPFP. I'm going to ignore the code.

  11. #11
    Join Date
    Nov 2011
    Posts
    453
    Rep Points
    662.4
    Mentioned
    17 Post(s)
    Rep Power
    7


    Reputation: Yes | No
    Flash back to stock? That sounds boring!!
    Click here to enlarge
    PTF Tuned Cobb Stage 2+ | H&R / Koni Sport | BBS LM

  12. #12
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    Reputation: Yes | No
    Click here to enlarge Originally Posted by JStang Click here to enlarge
    Flash back to stock? That sounds boring!!
    I just wanted to confirm that it's a tuned thing.

  13. #13
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    919
    Rep Points
    780.4
    Mentioned
    42 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    How much did you pay for LPFP and sensor? I am thinking of doing the same thing over the winter just for precaution.
    From all the things I've lost,
    I miss my mind the most!
    Click here to enlarge

  14. #14
    Join Date
    Feb 2012
    Posts
    389
    Rep Points
    2.0
    Mentioned
    20 Post(s)
    Rep Power
    0



    2 out of 2 members liked this post. Reputation: Yes | No
    Click here to enlarge Originally Posted by vasillalov Click here to enlarge
    How much did you pay for LPFP and sensor? I am thinking of doing the same thing over the winter just for precaution.
    ~$400 shipped. I bought it a while ago. It's Totally not worth it for someone with as little miles as you. I did some digging around on the other forum, and uncovered this on 2AAF (totally harmless code, if it appears alone occasionally): Click here to enlarge

  15. #15
    Join Date
    Jun 2010
    Location
    Chicago, IL
    Posts
    919
    Rep Points
    780.4
    Mentioned
    42 Post(s)
    Rep Power
    8


    Reputation: Yes | No
    Interesting find! Thanks for the info.
    From all the things I've lost,
    I miss my mind the most!
    Click here to enlarge

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •