Close

Page 3 of 3 FirstFirst 123
Results 51 to 52 of 52
  1. #51
    Join Date
    Feb 2010
    Location
    Miami
    Posts
    286
    Rep Points
    349.4
    Mentioned
    9 Post(s)
    Rep Power
    4



    Reputation: Yes | No
    Click here to enlarge Originally Posted by Rob@RBTurbo Click here to enlarge
    The front turbo is the same on all of them, and yes it is the one with the rod in between the turbo and the block. The rear one has a differently positioned actuator (which is the same Actuator as the front unit), but overall is pretty much the same thing. Hope the issue has been permanently cured, as the internal wastegates wear they definitely get the actuators way out of spec- but eventually they will start binding because of the wear pattern. Nevertheless you could be good for a while.
    Honestly, if I'm good for maybe 4 to 5 months is all I need, if all goes well probably even sooner.. Looking to get an LSD first to be able to put the power from your turbos down, then after install is another month to re-coupe and then pull the trigger.

    Thanks for all the help and feedback.
    || DCT | ESS Tune | ACM Test-pipes | AA Green Filter | Swift Spec-R Springs | Stoptech ST-40 F || || My Youtube Channel|| My Vimeo Channel ||

  2. #52
    Join Date
    Jan 2010
    Location
    SoCal
    Posts
    117,203
    Rep Points
    31,315.5
    Mentioned
    2056 Post(s)
    Rep Power
    314


    Reputation: Yes | No
    Click here to enlarge Originally Posted by yandyr Click here to enlarge
    if anyone's interested on a DIY for the 1series, since the turbos are different than the 3 series, I'll write it up.
    Yes, do it.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •