Close

Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2010
    Location
    Stockholm
    Posts
    1,528
    Rep Points
    1,177.6
    Mentioned
    61 Post(s)
    Rep Power
    12


    Yes Reputation No

    Another labonde crapped out.

    Seems today my labonte decided to stop reading flow....
    I have a Snow performance Safe Injection i could use to replace it. Anybody know if the wiring is the same? Basically can i connect the Labonte white connector wiring to the snow performance. I know snow developped it and improved it from the labonte.
    IF not can someone help me out with the wiring ?
    Thanks
    Enrico
    07 335i AT - MOTIV 750 - MHD BMS E85 - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
    Click here to enlarge

  2. #2
    Join Date
    Mar 2010
    Location
    AZ
    Posts
    2,729
    Rep Points
    2,484.0
    Mentioned
    40 Post(s)
    Rep Power
    25


    1 out of 1 members liked this post. Yes Reputation No
    Click here to enlarge Originally Posted by enrita Click here to enlarge
    Seems today my labonte decided to stop reading flow....
    I have a Snow performance Safe Injection i could use to replace it. Anybody know if the wiring is the same? Basically can i connect the Labonte white connector wiring to the snow performance. I know snow developped it and improved it from the labonte.
    IF not can someone help me out with the wiring ?
    Thanks
    Enrico
    i've owned both and knew the answer to this. But I think they operate differently unfortunately, but I can't remember. It may be the gauge signal thats different, not the input signals.

  3. #3
    Join Date
    Mar 2010
    Location
    Stockholm
    Posts
    1,528
    Rep Points
    1,177.6
    Mentioned
    61 Post(s)
    Rep Power
    12



    Yes Reputation No
    thanks, i have actually found online 2 pdf manuals. i think i can keep the wiring/connector and just switch the wires around in the right order for it to work on snow. will try tomorrow.
    07 335i AT - MOTIV 750 - MHD BMS E85 - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
    Click here to enlarge

  4. #4
    Join Date
    Apr 2010
    Location
    NYC
    Posts
    3,089
    Rep Points
    999.1
    Mentioned
    104 Post(s)
    Rep Power
    10


    Yes Reputation No
    The snow performance needs to be spliced into the pumps positive wire. Otherwise it's the same as labonte.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •